import Foundation
let pattern = #"^(?<indent>\s*)(?<mod1>\w+)\s(?<mod2>\w+)?\s*(?<mod3>\w+)?\s*(?<return>\b\w+)\s(?<name>\w+)\((?<arg>.*?)\)\s*\{(?<body>.+?)^\k<indent>\}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
public static FieldsConfig getFieldsConfig(){
if(xxx) {
sssss;
}
return;
}
public String getAsSeparateGroup(String groupName) {
String begin = pattern.substring(0,getStart());
String mid = pattern.substring(getStart(),getEnd());
String finish = pattern.substring(getEnd());
return begin + "(?<" + groupName + ">" + mid + ")" + finish;
}
@Override
public static final String toString() {
return asString;
}
public String directMatch(String match) {
Matcher matcher = Pattern.compile(getAsSeparateGroup("test")).matcher(match);
matcher.find();
String result;
try {
result = matcher.group("test");
}catch (Exception ex) {
result = "empty";
}
return getPattern() + ":" + result;
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)