const regex = /\G((?:(?:"(?:\\[\S\s]|[^"\\])*"|'(?:\\[\S\s]|[^'\\])*')|[^"'\s]+)*)\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G((?:(?:"(?:\\\\[\\S\\s]|[^"\\\\])*"|\'(?:\\\\[\\S\\s]|[^\'\\\\])*\')|[^"\'\\s]+)*)\\s+', 'g')
const str = `Word1 Word2`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);