re = /\G((?:(?:"(?:\\[\S\s]|[^"\\])*"|'(?:\\[\S\s]|[^'\\])*')|[^"'\s]+)*)\s+/
str = 'Word1 Word2'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result