$re = '/\G((?:(?:"(?:\\\\[\S\s]|[^"\\\\])*"|\'(?:\\\\[\S\s]|[^\'\\\\])*\')|[^"\'\s]+)*)\s+/';
$str = 'Word1 Word2';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;