using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(.*?) *(<[^ ]+@[^ ]+\.[^ ].+>)$)";
string input = @"*@*.com
khbj.com
njk123.kl kl.kmkk.lmlmklm@@@@.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}