package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(.*?) *(<[^ ]+@[^ ]+\.[^ ].+>)$)`)
var str = `*@*.com
khbj.com
njk123.kl kl.kmkk.lmlmklm@@@@.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}