re = /(^(.*?) *(<[^ ]+@[^ ]+\.[^ ].+>)$)/m
str = '*@*.com
khbj.com
njk123.kl kl.kmkk.lmlmklm@@@@.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end