#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(?:(?=\S*\d)\S+(?:\s+(?=\S*\d)\S+)*\W*)?\K\S*"
Local $sString = "First12word50 Secųond-Word Thirdųword ' result must be Secųond-Word" & @CRLF & _
"First1-2word50 Secųond/Word Thirdųword ' result must be Secųond/Word" & @CRLF & _
"First1/2word50 Secųond+Word Thirdųword ' result must be Secųond+Word" & @CRLF & _
"First1/2word50 Secųond1+Word Thirdų-word ' result must be Thirdų-word" & @CRLF & _
"First1/2word50 Sec1ųond1+Word Thir11dų-word"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")