$re = '/^(?:(?=\S*\d)\S+(?:\s+(?=\S*\d)\S+)*\W*)?\K\S*/mu';
$str = 'First12word50 Secųond-Word Thirdųword \' result must be Secųond-Word
First1-2word50 Secųond/Word Thirdųword \' result must be Secųond/Word
First1/2word50 Secųond+Word Thirdųword \' result must be Secųond+Word
First1/2word50 Secųond1+Word Thirdų-word \' result must be Thirdų-word
First1/2word50 Sec1ųond1+Word Thir11dų-word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);