#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{6,}(?=\D)(?!\.)|\d{6,}(?=$)"
Local $sString = "123 => invalid" & @CRLF & _
"123456 => 123456" & @CRLF & _
"123456.12 => invalid" & @CRLF & _
"abcd1234567efg => 1234567" & @CRLF & _
"abcd1234567.123efg => invalid" & @CRLF & _
"abc123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")