use strict;
my $str = '123 => invalid
123456 => 123456
123456.12 => invalid
abcd1234567efg => 1234567
abcd1234567.123efg => invalid
abc123456';
my $regex = qr/\d{6,}(?=\D)(?!\.)|\d{6,}(?=$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}