$re = '/\d{6,}(?=\D)(?!\.)|\d{6,}(?=$)/m';
$str = '123 => invalid
123456 => 123456
123456.12 => invalid
abcd1234567efg => 1234567
abcd1234567.123efg => invalid
abc123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);