using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\b(?<![.,])(\d[\d.,]*)";
string input = @"Sum of elements 1 - 4 is 16.4 total";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}