const regex = /.*\b(?<![.,])(\d[\d.,]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\b(?<![.,])(\\d[\\d.,]*)', '')
const str = `Sum of elements 1 - 4 is 16.4 total`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}