using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"PT((?P<hours>\d+)H)?((?P<minutes>\d+)M)?((?P<seconds>\d+)S)?";
string input = @"PT1H
PT23M
PT45S
PT1H23M
PT1H45S
PT23M45S
PT1H23M45S";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}