re = /PT((?P<hours>\d+)H)?((?P<minutes>\d+)M)?((?P<seconds>\d+)S)?/
str = 'PT1H
PT23M
PT45S
PT1H23M
PT1H45S
PT23M45S
PT1H23M45S'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end