$re = '/PT((?P<hours>\d+)H)?((?P<minutes>\d+)M)?((?P<seconds>\d+)S)?/';
$str = 'PT1H
PT23M
PT45S
PT1H23M
PT1H45S
PT23M45S
PT1H23M45S';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);