use strict;
my $str = '12+3=15';
my $regex = qr/\b/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";