import re
regex = re.compile(r"\b", flags=re.MULTILINE)
test_str = "12+3=15"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)