using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo\.[ab][\s\S]*?(?=\n.*?=|$)";
string input = @"foo.a = [10
20
30
40];
foo.b = 'foobar';";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}