$re = '/foo\.[ab][\s\S]*?(?=\n.*?=|$)/';
$str = 'foo.a = [10
20
30
40];
foo.b = \'foobar\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);