import re
regex = re.compile(r"foo\.[ab][\s\S]*?(?=\n.*?=|$)")
test_str = ("foo.a = [10\n"
"20\n"
"30\n"
"40];\n\n"
"foo.b = 'foobar';")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")