import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*)([a-zA-Z0-9]{2})(?:\\s*)";
final String string = "c 59 e5 04 d8 09 00 24 43 b8 d2 1a 08 00 45 00\n"
+ "00 30 61 7c 00 00 1d 06 99 4c ac 11 4 19 0a c\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}