const regex = /(?:\s*)([a-zA-Z0-9]{2})(?:\s*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*)([a-zA-Z0-9]{2})(?:\\s*)', 'gm')
const str = `c 59 e5 04 d8 09 00 24 43 b8 d2 1a 08 00 45 00
00 30 61 7c 00 00 1d 06 99 4c ac 11 4 19 0a c
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}