#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "S\d{8}"
Local $sString = "[2] http://statistics.gov.scot/id/statistical-geography/S02000002" & @CRLF & _
" [3] http://statistics.gov.scot/id/statistical-geography/S02000003" & @CRLF & _
" [4] http://statistics.gov.scot/id/statistical-geography/S02000004" & @CRLF & _
" [5] http://statistics.gov.scot/id/statistical-geography/S02000005" & @CRLF & _
" [6] http://statistics.gov.scot/id/statistical-geography/S02000006" & @CRLF & _
" [7] http://statistics.gov.scot/id/statistical-geography/S02000007" & @CRLF & _
" [8] http://statistics.gov.scot/id/statistical-geography/S02000008" & @CRLF & _
" [9] http://statistics.gov.scot/id/statistical-geography/S02000009" & @CRLF & _
" [10] http://statistics.gov.scot/id/statistical-geography/S02000010" & @CRLF & _
" [11] http://statistics.gov.scot/id/statistical-geography/S02000011" & @CRLF & _
" [12] http://statistics.gov.scot/id/statistical-geography/S02000012"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")