re = /S\d{8}/
str = '[2] http://statistics.gov.scot/id/statistical-geography/S02000002
[3] http://statistics.gov.scot/id/statistical-geography/S02000003
[4] http://statistics.gov.scot/id/statistical-geography/S02000004
[5] http://statistics.gov.scot/id/statistical-geography/S02000005
[6] http://statistics.gov.scot/id/statistical-geography/S02000006
[7] http://statistics.gov.scot/id/statistical-geography/S02000007
[8] http://statistics.gov.scot/id/statistical-geography/S02000008
[9] http://statistics.gov.scot/id/statistical-geography/S02000009
[10] http://statistics.gov.scot/id/statistical-geography/S02000010
[11] http://statistics.gov.scot/id/statistical-geography/S02000011
[12] http://statistics.gov.scot/id/statistical-geography/S02000012'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end