import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "S\\d{8}";
final String string = "[2] http://statistics.gov.scot/id/statistical-geography/S02000002\n"
+ " [3] http://statistics.gov.scot/id/statistical-geography/S02000003\n"
+ " [4] http://statistics.gov.scot/id/statistical-geography/S02000004\n"
+ " [5] http://statistics.gov.scot/id/statistical-geography/S02000005\n"
+ " [6] http://statistics.gov.scot/id/statistical-geography/S02000006\n"
+ " [7] http://statistics.gov.scot/id/statistical-geography/S02000007\n"
+ " [8] http://statistics.gov.scot/id/statistical-geography/S02000008\n"
+ " [9] http://statistics.gov.scot/id/statistical-geography/S02000009\n"
+ " [10] http://statistics.gov.scot/id/statistical-geography/S02000010\n"
+ " [11] http://statistics.gov.scot/id/statistical-geography/S02000011\n"
+ " [12] http://statistics.gov.scot/id/statistical-geography/S02000012";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}