using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(?:''|--))[a-z][a-z'-]+[a-z]$";
string input = @"asd----asd''asd
a-s-s's-dsdsd'sd'sd'sdsd
asdsad'''asdsd-sadasd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}