re = /^(?!.*(?:''|--))[a-z][a-z'-]+[a-z]$/m
str = 'asd----asd\'\'asd
a-s-s\'s-dsdsd\'sd\'sd\'sdsd
asdsad\'\'\'asdsd-sadasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end