$re = '/^(?!.*(?:\'\'|--))[a-z][a-z\'-]+[a-z]$/m';
$str = 'asd----asd\'\'asd
a-s-s\'s-dsdsd\'sd\'sd\'sdsd
asdsad\'\'\'asdsd-sadasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);