using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^admin(?:\/(?P<controller>[a-z-]+)(?:\/(?P<action>[a-z-]+))?)?\/?$";
string input = @"home
administrator
admin
admin/
admin/users/index";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}