re = /^admin(?:\/(?P<controller>[a-z-]+)(?:\/(?P<action>[a-z-]+))?)?\/?$/mi
str = 'home
administrator
admin
admin/
admin/users/index'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end