$re = '/^admin(?:\/(?P<controller>[a-z-]+)(?:\/(?P<action>[a-z-]+))?)?\/?$/mi';
$str = 'home
administrator
admin
admin/
admin/users/index';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);