#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<img\b[^<>]*\bsrc="[^\s"]*/([^\s]+)\.\w+")([^<>]*\balt=")("[^<>]*>)"
Local $sString = "<img class="alignnone size-medium wp-image-18" src="http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg" alt="" width="300" height="149">"
Local $sSubst = "$1$3$2$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)