use strict;
my $str = '<img class="alignnone size-medium wp-image-18" src="http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg" alt="" width="300" height="149">';
my $regex = qr~(<img\b[^<>]*\bsrc="[^\s"]*/([^\s]+)\.\w+")([^<>]*\balt=")("[^<>]*>)~p;
my $subst = '$1$3$2$4';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";