// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<img\b[^<>]*\bsrc="[^\s"]*/([^\s]+)\.\w+")([^<>]*\balt=")("[^<>]*>)"#).unwrap();
let string = "<img class=\"alignnone size-medium wp-image-18\" src=\"http://localhost/wp-content/uploads/2015/02/300x149-jquerymobile.jpg\" alt=\"\" width=\"300\" height=\"149\">";
let substitution = "$1$3$2$4";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}