using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\.\s*ABC[^\S\n]*(?:\n.+)*";
string input = @"1. Hello world
1.1 bla bla bla
1.2 more bla bla
1.3 even more bla bla ABC
2. ABC
2.1 hello ABC
2.2 bla bla bla
3. XYZ
3.1 bla bla
3.2 more bla bla
3.3 even more bla bla
1. Hello world
1.1 bla bla bla
1.2 more bla bla
1.3 even more bla bla ABC
2. XYZ
2.1 bla bla
2.2 more bla bla
2.3 even more bla bla
3. MNO
3.1 hello MNO
3.2 bla bla bla
4. ABC
4.1 hello ABC
4.2 bla bla bla";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}