import re
regex = re.compile(r"^\d+\.\s*ABC[^\S\n]*(?:\n.+)*", flags=re.MULTILINE)
test_str = ("1. Hello world\n"
"1.1 bla bla bla\n"
"1.2 more bla bla\n"
"1.3 even more bla bla ABC\n\n"
"2. ABC \n"
"2.1 hello ABC\n"
"2.2 bla bla bla\n\n"
"3. XYZ\n"
"3.1 bla bla\n"
"3.2 more bla bla\n"
"3.3 even more bla bla\n\n"
"1. Hello world\n"
"1.1 bla bla bla\n"
"1.2 more bla bla\n"
"1.3 even more bla bla ABC\n\n"
"2. XYZ\n"
"2.1 bla bla\n"
"2.2 more bla bla\n"
"2.3 even more bla bla\n\n"
"3. MNO \n"
"3.1 hello MNO\n"
"3.2 bla bla bla\n\n"
"4. ABC \n"
"4.1 hello ABC\n"
"4.2 bla bla bla")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")