import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\.\\s*ABC[^\\S\\n]*(?:\\n.+)*";
final String string = "1. Hello world\n"
+ "1.1 bla bla bla\n"
+ "1.2 more bla bla\n"
+ "1.3 even more bla bla ABC\n\n"
+ "2. ABC \n"
+ "2.1 hello ABC\n"
+ "2.2 bla bla bla\n\n"
+ "3. XYZ\n"
+ "3.1 bla bla\n"
+ "3.2 more bla bla\n"
+ "3.3 even more bla bla\n\n"
+ "1. Hello world\n"
+ "1.1 bla bla bla\n"
+ "1.2 more bla bla\n"
+ "1.3 even more bla bla ABC\n\n"
+ "2. XYZ\n"
+ "2.1 bla bla\n"
+ "2.2 more bla bla\n"
+ "2.3 even more bla bla\n\n"
+ "3. MNO \n"
+ "3.1 hello MNO\n"
+ "3.2 bla bla bla\n\n"
+ "4. ABC \n"
+ "4.1 hello ABC\n"
+ "4.2 bla bla bla";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}