import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?=.{0,10}\\))([^)]+)\\)";
final String string = "(some text) some other text -> some text\n"
+ "(some) some other text -> some\n"
+ "(12345) some other text -> 12345\n"
+ "(TooLongStri) -> nothing matched because 11 characters";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}