import re
regex = re.compile(r"\((?=.{0,10}\))([^)]+)\)", flags=re.MULTILINE)
test_str = ("(some text) some other text -> some text\n"
"(some) some other text -> some\n"
"(12345) some other text -> 12345\n"
"(TooLongStri) -> nothing matched because 11 characters")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")