$re = '/^[^\s.]+(?:\.(?!(?:bat|exe|js|sh)\b)\w+)?\.(?:pdf|xls)$/m';
$str = 'file.pdf
file.xls
i want to exclude
file.sh
file.exe
file.js
or
file.bat
filename.exe.pdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);