import re
regex = re.compile(r"^[^\s.]+(?:\.(?!(?:bat|exe|js|sh)\b)\w+)?\.(?:pdf|xls)$", flags=re.MULTILINE)
test_str = ("file.pdf\n"
"file.xls\n"
"i want to exclude\n"
"file.sh\n"
"file.exe\n"
"file.js\n"
" or \n"
"file.bat\n"
"filename.exe.pdf\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")