re = /^[^\s.]+(?:\.(?!(?:bat|exe|js|sh)\b)\w+)?\.(?:pdf|xls)$/m
str = 'file.pdf
file.xls
i want to exclude
file.sh
file.exe
file.js
or
file.bat
filename.exe.pdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end