# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\s)@([A-z]+)\b/$2/gi;t' <<< "@whatever
whatever
"