$re = '/(^|\s)@([A-z]+)\b/i';
$str = '@whatever
whatever
';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;