use strict;
my $str = '@whatever
whatever
';
my $regex = qr/(^|\s)@([A-z]+)\b/ip;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";