#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\$\!(define|execute)\.function\$\n\:(\w{7,20})\:\n\:\n([\S|\s]+)\n\:\n\$\!(mod|user)\.console\.end\$)"
Local $sString = "abcdefghijklmnopqrstuvwxyz" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"0123456789" & @CRLF & _
"!@#$%^&*()-_=+{[}]|\/:;'"`~" & @CRLF & _
"" & @CRLF & _
"$!define.function$" & @CRLF & _
":functi2onname:" & @CRLF & _
":" & @CRLF & _
"def here():" & @CRLF & _
" return xy" & @CRLF & _
"y = 5" & @CRLF & _
"y = {}" & @CRLF & _
"t = [90,["hello"]]" & @CRLF & _
"s = 50" & @CRLF & _
"z = x + y" & @CRLF & _
"print('eeee')" & @CRLF & _
":" & @CRLF & _
"$!mod.console.end$" & @CRLF & _
"" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"0123456789" & @CRLF & _
"!@#$%^&*()-_=+{[}]|\/:;'"`~" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")