$re = '/(\$\!(define|execute)\.function\$\n\:(\w{7,20})\:\n\:\n([\S|\s]+)\n\:\n\$\!(mod|user)\.console\.end\$)/';
$str = 'abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789
!@#$%^&*()-_=+{[}]|\\/:;\'"`~
$!define.function$
:functi2onname:
:
def here():
return xy
y = 5
y = {}
t = [90,["hello"]]
s = 50
z = x + y
print(\'eeee\')
:
$!mod.console.end$
abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789
!@#$%^&*()-_=+{[}]|\\/:;\'"`~
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);