use strict;
my $str = 'abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789
!@#$%^&*()-_=+{[}]|\\/:;\'"`~
$!define.function$
:functi2onname:
:
def here():
return xy
y = 5
y = {}
t = [90,["hello"]]
s = 50
z = x + y
print(\'eeee\')
:
$!mod.console.end$
abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789
!@#$%^&*()-_=+{[}]|\\/:;\'"`~
';
my $regex = qr/(\$\!(define|execute)\.function\$\n\:(\w{7,20})\:\n\:\n([\S|\s]+)\n\:\n\$\!(mod|user)\.console\.end\$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}